Pending Screening Reports
Incident Report for On-Site.com
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 16:07 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2024 - 14:18 CDT
Identified
We are aware that some of our third-party vendors are impacted by the global Microsoft/CrowdStrike issues. Some background screening reports may be pending until these issues are resolved. We are monitoring this situation closely.
Posted Jul 19, 2024 - 11:00 CDT
This incident affected: Leasing Suite (Screening).