New York 2-year Renewal Documents
Incident Report for On-Site.com
Resolved
We have resolved the issue and restored service.
Posted Aug 18, 2023 - 12:21 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 18, 2023 - 10:00 PDT
Identified
For New York Only:
We have identified an issue with how 2-year renewal amounts are displaying on the renewal lease form, and are working towards a resolution. Please hold off on sending renewals out until this is resolved.
Posted Aug 18, 2023 - 09:48 PDT
This incident affected: Leasing Suite (Document Services).