PayLease stability issues
Incident Report for On-Site.com
Resolved
PayLease has confirmed that the underlying issues with stability have been resolved. We are continuing to monitor performance and availability.
Posted 10 months ago. Sep 01, 2017 - 12:44 PDT
Monitoring
PayLease is currently experiencing production stability issues. We are aware of the situation and are monitoring closely. This will affect all payments processed by PayLease included application fees, holding deposits, and rent payments through Resident Passport. We will provide updates as more information becomes available. This does not affect On-Site Payments.
Posted 10 months ago. Sep 01, 2017 - 11:23 PDT