Some Landlord Tenant Screenings Are "Pending" Status
Incident Report for On-Site.com
Resolved
This issue has been resolved.
Posted 10 months ago. Jul 17, 2018 - 15:30 PDT
Monitoring
We have identified the issue and are working on a fix.
Posted 10 months ago. Jul 17, 2018 - 13:28 PDT
Investigating
We are investigating an issue with some landlord tenant searches being stuck on "Pending" status. We will provide updates as soon as we have more information.
Posted 10 months ago. Jul 17, 2018 - 13:23 PDT
This incident affected: Leasing Suite (Screening).